# CVE-2025-4101: Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions

> Authenticated contributors can delete arbitrary posts and products due to incorrect authorization checks in the MultiVendorX WooCommerce plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 May 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-8743-487v-2xqh

## What is CVE-2025-4101?

CVE-2025-4101 is a medium-severity missing authorization vulnerability in wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The MultiVendorX – WooCommerce Multivendor Marketplace Solutions plugin for WordPress is vulnerable to unauthorized loss of data due to a misconfigured capability check on the 'delete_fpm_product' function in all versions up to, and including, 4.2.22. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary posts, pages, attachments, and products. The vulnerability was partially patched in version 4.2.22.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-4101?

It affects 1 product.


Products: Multivendorx Multivendorx.

## How do I fix CVE-2025-4101?

No fix has been published for CVE-2025-4101 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-4101 being exploited?

There is no known exploitation of CVE-2025-4101 in the wild and no public exploit code.

## Other vulnerabilities in wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions

- [CVE-2025-0493](https://insights.sbomify.com/CVE-2025-0493/): Path traversal in MultiVendorX – WooCommerce Multivendor Marketplace Solutions (critical 9.8)
- [CVE-2024-8289](https://insights.sbomify.com/CVE-2024-8289/): Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions (critical 9.8)
- [CVE-2025-48261](https://insights.sbomify.com/CVE-2025-48261/): WordPress MultiVendorX plugin <= 4.2.22 - Sensitive Data Exposure Vulnerability (high 7.5)
- [CVE-2024-31304](https://insights.sbomify.com/CVE-2024-31304/): WordPress MultiVendorX Marketplace <= 4.1.3 - Broken Access Control vulnerability (high 7.1)
- [CVE-2025-48263](https://insights.sbomify.com/CVE-2025-48263/): WordPress MultiVendorX plugin <= 4.2.22 - Cross Site Scripting (XSS) Vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4101 and fix it if it is affected.

What it is: CVE-2025-4101 is a medium-severity missing authorization vulnerability in wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions, published on 17 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4101 in the wild and no public exploit code.

Affected product: wcmp MultiVendorX – WooCommerce Multivendor Marketplace Solutions. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4101/ (Markdown: https://insights.sbomify.com/CVE-2025-4101/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4101
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4101
- OSV: https://osv.dev/vulnerability/CVE-2025-4101

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4101/
Summaries are generated and may contain mistakes; the official description above is the record.
