CVE-2025-4102 Beaver Builder Plugin (Starter Version) <= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload
Administrators can upload arbitrary files via missing validation, potentially leading to remote code execution on the server.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-4102?
CVE-2025-4102 is a high-severity vulnerability in The Beaver Builder Team Beaver Builder Plugin (Starter Version), published on 20 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.
Weakness: CWE-434
Which versions are affected by CVE-2025-4102?
It affects 1 product.
Products include Fastlinemedia Beaver Builder.
How do I fix CVE-2025-4102?
No fix has been published for CVE-2025-4102 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-4102 being exploited?
There is no known exploitation of CVE-2025-4102 in the wild and no public exploit code.
Other vulnerabilities in The Beaver Builder Team Beaver Builder Plugin (Starter Version)
- CVE-2024-43926 WordPress Beaver Builder plugin <= 2.8.3.2 - Reflected Cross Site Scripting (XSS) vulnerability
- CVE-2024-53797 WordPress Beaver Builder plugin <= 2.8.4.3 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-50430 WordPress Beaver Builder plugin <= 2.8.3.7 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-37500 WordPress Beaver Builder plugin <= 2.8.2.2 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-30425 WordPress Beaver Builder plugin <= 2.7.4.4 - Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-c4hq-vq7x-9xjf.