{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-4102 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-4102 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-4102 is a high-severity vulnerability in The Beaver Builder Team Beaver Builder Plugin (Starter Version), published on 20 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-4102 and fix it if it is affected.\n\nWhat it is: CVE-2025-4102 is a high-severity vulnerability in The Beaver Builder Team Beaver Builder Plugin (Starter Version), published on 20 Jun 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-4102 in the wild and no public exploit code.\n\nAffected product: The Beaver Builder Team Beaver Builder Plugin (Starter Version). No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4102/ (Markdown: https://insights.sbomify.com/CVE-2025-4102/index.md)","id":"CVE-2025-4102","markdown":"https://insights.sbomify.com/CVE-2025-4102/index.md","name":"CVE-2025-4102","record":{"aliases":["GHSA-c4hq-vq7x-9xjf"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Administrators can upload arbitrary files via missing validation, potentially leading to remote code execution on the server.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"beaver_builder","vendor":"fastlinemedia"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Beaver Builder Plugin (Starter Version) \u003c= 2.9.1 - Authenticated (Administrator+) Arbitrary File Upload","id":"CVE-2025-4102","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"file_upload","year":"2025"},"n_packages":0,"n_references":2,"next":{"headline":"Missing authorization in WP-GeoMeta","id":"CVE-2025-4103"},"packages":[],"prev":{"headline":"Missing authorization in MultiVendorX – WooCommerce Multivendor Marketplace Solutions","id":"CVE-2025-4101"},"products":["Beaver Builder Plugin (Starter Version)"],"published":"2025-06-20","related":[{"cvss_score":7.1,"headline":"WordPress Beaver Builder plugin \u003c= 2.8.3.2 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-43926","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":6.5,"headline":"WordPress Beaver Builder plugin \u003c= 2.8.4.3 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-53797","kev_date_added":null,"published":"2024-12-06"},{"cvss_score":6.5,"headline":"WordPress Beaver Builder plugin \u003c= 2.8.3.7 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-50430","kev_date_added":null,"published":"2024-11-19"},{"cvss_score":6.5,"headline":"WordPress Beaver Builder plugin \u003c= 2.8.2.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-37500","kev_date_added":null,"published":"2024-07-21"},{"cvss_score":6.5,"headline":"WordPress Beaver Builder plugin \u003c= 2.7.4.4 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-30425","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":6.5,"headline":"WordPress Beaver Builder Plugin \u003c= 2.7.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-50889","kev_date_added":null,"published":"2023-12-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["The Beaver Builder Team"]},"summary":"Administrators can upload arbitrary files via missing validation, potentially leading to remote code execution on the server.","url":"https://insights.sbomify.com/CVE-2025-4102/"}