# CVE-2025-41118: Sensitive COS `SecretKey` exposed in plaintext via configuration API due to missing type protection

> Attackers with API access can extract Tencent COS SecretKey in plaintext if COS backend is configured, exposing cloud credentials.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 27 Aug 2026
- **Also known as:** BIT-grafana-pyroscope-2025-41118, GHSA-m9hq-h476-h2g8, GO-2026-5501

## What is CVE-2025-41118?

CVE-2025-41118 is a critical vulnerability in Grafana Pyroscope, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pyroscope is an open-source continuous profiling database. The database supports various storage backends, including Tencent Cloud Object Storage (COS).

If the database is configured to use Tencent COS as the storage backend, an attacker could extract the secret_key configuration value from the Pyroscope API.

To exploit this vulnerability, an attacker needs direct access to the Pyroscope API. We highly recommend limiting the public internet exposure of all our databases, such that they are only accessible by trusted users or internal systems.

This vulnerability is fixed in versions:

1.15.x: 1.15.2 and above.
1.16.x: 1.16.1 and above.
1.17.x: 1.17.0 and above (i.e. all versions).

Thanks to Théo Cusnir for reporting this vulnerability to us via our bug bounty program.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data), CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2025-41118?

6 open source packages ship an affected version, including github.com/grafana/pyroscope and grafana-pyroscope. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/pyroscope` | Go | All versions | 1.15.2, 1.16.1 |
| `github.com/grafana/pyroscope` | Go | All versions | 1.15.2 |
| `github.com/grafana/pyroscope` | Go | All versions | 1.15.2 |
| `github.com/grafana/pyroscope` | Go | From 1.16.0 | 1.16.1 |
| `github.com/grafana/pyroscope` | Go | From 1.16.0 | 1.16.1 |
| `grafana-pyroscope` | Bitnami | All versions | 1.15.2, 1.17.0 |

Products: Grafana Pyroscope.

## How do I fix CVE-2025-41118?

Upgrade github.com/grafana/pyroscope to a fixed version for your release line: 1.15.2 or 1.16.1.

## Is CVE-2025-41118 being exploited?

There is no known exploitation of CVE-2025-41118 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41118 and fix it if it is affected.

What it is: CVE-2025-41118 is a critical vulnerability in Grafana Pyroscope, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-41118 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/pyroscope (Go): affected all versions; fixed in 1.15.2, 1.16.1
- github.com/grafana/pyroscope (Go): affected all versions; fixed in 1.15.2
- github.com/grafana/pyroscope (Go): affected all versions; fixed in 1.15.2
- github.com/grafana/pyroscope (Go): affected from 1.16.0; fixed in 1.16.1
- github.com/grafana/pyroscope (Go): affected from 1.16.0; fixed in 1.16.1
- grafana-pyroscope (Bitnami): affected all versions; fixed in 1.15.2, 1.17.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41118/ (Markdown: https://insights.sbomify.com/CVE-2025-41118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41118
- OSV: https://osv.dev/vulnerability/CVE-2025-41118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41118/
Summaries are generated and may contain mistakes; the official description above is the record.
