# CVE-2025-41235: CVE-2025-41235: Spring Cloud Gateway Server Forwards Headers from Untrusted Proxies

> Attackers can spoof IP addresses by injecting headers from untrusted proxies, bypassing IP-based security controls in Spring Cloud Gateway.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 May 2025
- **Updated:** 30 May 2025
- **Also known as:** CLSA-2026-1777509591, GHSA-6j2q-c73v-97c5

## What is CVE-2025-41235?

CVE-2025-41235 is a high-severity vulnerability in VMware Spring Cloud Gateway Server MVC, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Cloud Gateway Server forwards the X-Forwarded-For and Forwarded headers from untrusted proxies.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-41235?

10 open source packages ship an affected version, including org.springframework.cloud:spring-cloud-gateway-server-mvc and org.springframework.cloud:spring-cloud-gateway-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.cloud:spring-cloud-gateway-server-mvc` | Maven | From 4.1.7 | 4.2.3 |
| `org.springframework.cloud:spring-cloud-gateway-server-mvc` | Maven | From 4.1.7 | 4.2.3 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | All versions | 3.1.10 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | All versions | 3.1.10 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.0.0 to 4.0.9 | None |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.0.0 to 4.0.9 | None |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.1.0 | 4.1.8 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.1.0 | 4.1.8 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.2.0 | 4.2.3 |
| `org.springframework.cloud:spring-cloud-gateway-server` | Maven | From 4.2.0 | 4.2.3 |

## How do I fix CVE-2025-41235?

Upgrade org.springframework.cloud:spring-cloud-gateway-server-mvc to 4.2.3 or later.

## Is CVE-2025-41235 being exploited?

There is no known exploitation of CVE-2025-41235 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41235 and fix it if it is affected.

What it is: CVE-2025-41235 is a high-severity vulnerability in VMware Spring Cloud Gateway Server MVC, published on 30 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-41235 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.cloud:spring-cloud-gateway-server-mvc (Maven): affected from 4.1.7; fixed in 4.2.3
- org.springframework.cloud:spring-cloud-gateway-server-mvc (Maven): affected from 4.1.7; fixed in 4.2.3
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected all versions; fixed in 3.1.10
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected all versions; fixed in 3.1.10
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.0.0 up to 4.0.9; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.0.0 up to 4.0.9; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.1.0; fixed in 4.1.8
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.1.0; fixed in 4.1.8
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.2.0; fixed in 4.2.3
- org.springframework.cloud:spring-cloud-gateway-server (Maven): affected from 4.2.0; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41235/ (Markdown: https://insights.sbomify.com/CVE-2025-41235/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41235
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41235
- OSV: https://osv.dev/vulnerability/CVE-2025-41235

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41235/
Summaries are generated and may contain mistakes; the official description above is the record.
