# CVE-2025-41243: Spring Expression Language property modification using Spring Cloud Gateway Server WebFlux

> Attackers can modify Spring Environment properties via exposed actuator endpoints, potentially leading to code execution or privilege escalation.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-q2cj-h8fw-q4cc, ROOT-APP-MAVEN-CVE-2025-41243

## What is CVE-2025-41243?

CVE-2025-41243 is a critical code injection vulnerability in Spring Cloud Gateway, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Cloud Gateway Server Webflux may be vulnerable to Spring Environment property modification.

An application should be considered vulnerable when all the following are true:

  *  The application is using Spring Cloud Gateway Server Webflux (Spring Cloud Gateway Server WebMVC is not vulnerable).
  *  Spring Boot actuator is a dependency.
  *  The Spring Cloud Gateway Server Webflux actuator web endpoint is enabled via management.endpoints.web.exposure.include=gateway.
  *  The actuator endpoints are available to attackers.
  *  The actuator endpoints are unsecured.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2025-41243?

8 open source packages ship an affected version, including org.springframework.cloud:spring-cloud-gateway-server-webflux.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 3.1.0 to 3.1.10 | None |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 3.1.0 to 3.1.10 | None |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.0.0 to 4.1.10 | None |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.0.0 to 4.1.10 | None |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.2.0 | 4.2.5 |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.2.0 | 4.2.5 |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.3.0 | 4.3.1 |
| `org.springframework.cloud:spring-cloud-gateway-server-webflux` | Maven | From 4.3.0 | 4.3.1 |

## How do I fix CVE-2025-41243?

Upgrade org.springframework.cloud:spring-cloud-gateway-server-webflux to a fixed version for your release line: 4.2.5 or 4.3.1.

## Is CVE-2025-41243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-41243 exists.

Public exploit code:

- Spring Cloud Gateway SpEL RCE Vulnerability Environment (github_poc): https://github.com/SFN233/CVE-2025-41243-Vulnerability-Lab
- Spring Cloud Gateway Server Webflux - Broken Access Control (nuclei): http/cves/2025/CVE-2025-41243.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41243 and fix it if it is affected.

What it is: CVE-2025-41243 is a critical code injection vulnerability in Spring Cloud Gateway, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-41243 exists.

Affected packages and fixed versions:
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 3.1.0 up to 3.1.10; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 3.1.0 up to 3.1.10; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.0.0 up to 4.1.10; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.0.0 up to 4.1.10; no fix listed
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.2.0; fixed in 4.2.5
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.2.0; fixed in 4.2.5
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.3.0; fixed in 4.3.1
- org.springframework.cloud:spring-cloud-gateway-server-webflux (Maven): affected from 4.3.0; fixed in 4.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41243/ (Markdown: https://insights.sbomify.com/CVE-2025-41243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41243
- OSV: https://osv.dev/vulnerability/CVE-2025-41243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41243/
Summaries are generated and may contain mistakes; the official description above is the record.
