# CVE-2025-41254: Spring Framework STOMP CSRF Vulnerability

> Attackers can send unauthorized messages in STOMP over WebSocket applications due to a CSRF vulnerability in Spring Framework.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** CLEANSTART-2026-KB50222, CLSA-2025-1761523598, CLSA-2025-1761523599, CLSA-2026-1773015249, CLSA-2026-1792115364, DEBIAN-CVE-2025-41254, ECHO-14e2-24d9-5f88, GHSA-7fch-4f2f-jcgm, ROOT-APP-MAVEN-CVE-2025-41254, UBUNTU-CVE-2025-41254

## What is CVE-2025-41254?

CVE-2025-41254 is a medium-severity vulnerability in VMware Spring Framework, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

STOMP over WebSocket applications may be vulnerable to a security bypass that allows an attacker to send unauthorized messages.

Affected Spring Products and VersionsSpring Framework:

  *  6.2.0 - 6.2.11
  *  6.1.0 - 6.1.23
  *  6.0.x - 6.0.29
  *  5.3.0 - 5.3.45
  *  Older, unsupported versions are also affected.

MitigationUsers of affected versions should upgrade to the corresponding fixed version.

Affected version(s)Fix versionAvailability6.2.x6.2.12OSS6.1.x6.1.24 Commercial https://enterprise.spring.io/ 6.0.xN/A Out of support https://spring.io/projects/spring-framework#support 5.3.x5.3.46 Commercial https://enterprise.spring.io/ No further mitigation steps are necessary.

CreditThis vulnerability was discovered and responsibly reported by Jannis Kaiser.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-41254?

8 open source packages ship an affected version, including org.springframework:spring-websocket.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-websocket` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-websocket` | Maven | All versions to 5.3.39 | None |
| `org.springframework:spring-websocket` | Maven | From 6.0.0 to 6.0.23 | None |
| `org.springframework:spring-websocket` | Maven | From 6.0.0 to 6.0.23 | None |
| `org.springframework:spring-websocket` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-websocket` | Maven | From 6.1.0 to 6.1.21 | None |
| `org.springframework:spring-websocket` | Maven | From 6.2.0 | 6.2.12 |
| `org.springframework:spring-websocket` | Maven | From 6.2.0 | 6.2.12 |

## How do I fix CVE-2025-41254?

Upgrade org.springframework:spring-websocket to 6.2.12 or later.

## Is CVE-2025-41254 being exploited?

There is no known exploitation of CVE-2025-41254 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41254 and fix it if it is affected.

What it is: CVE-2025-41254 is a medium-severity vulnerability in VMware Spring Framework, published on 16 Oct 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-41254 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-websocket (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-websocket (Maven): affected all versions up to 5.3.39; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.0.0 up to 6.0.23; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.0.0 up to 6.0.23; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.1.0 up to 6.1.21; no fix listed
- org.springframework:spring-websocket (Maven): affected from 6.2.0; fixed in 6.2.12
- org.springframework:spring-websocket (Maven): affected from 6.2.0; fixed in 6.2.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41254/ (Markdown: https://insights.sbomify.com/CVE-2025-41254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41254
- OSV: https://osv.dev/vulnerability/CVE-2025-41254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41254/
Summaries are generated and may contain mistakes; the official description above is the record.
