CVE-2025-4128 Mattermost Guest User Information Disclosure Vulnerability
Guest users can bypass permissions to view public team information via direct API calls, exposing sensitive data to unauthorized parties.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-4128?
CVE-2025-4128 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly restrict API access to team information, allowing guest users to bypass permissions and view information about public teams they are not members of via a direct API call to /api/v4/teams/{team_id}.
Weakness: CWE-863
Which versions are affected by CVE-2025-4128?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.5 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.5 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.14 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.14 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.14+incompatible, 10.5.5+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
4 more packages
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250422131222-701ddc896a10 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250422131222-701ddc896a10 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250422131222-701ddc896a10 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-4128?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.5, 9.11.14, 9.11.14+incompatible or 10.5.5+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-4128 being exploited?
There is no known exploitation of CVE-2025-4128 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-jwhw-xf5v-qgxc, GO-2025-3757.