# CVE-2025-4128: Mattermost Guest User Information Disclosure Vulnerability

> Guest users can bypass permissions to view public team information via direct API calls, exposing sensitive data to unauthorized parties.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2025
- **Updated:** 11 Jun 2025
- **Also known as:** GHSA-jwhw-xf5v-qgxc, GO-2025-3757

## What is CVE-2025-4128?

CVE-2025-4128 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.5.x <= 10.5.4, 9.11.x <= 9.11.13 fail to properly restrict API access to team information, allowing guest users to bypass permissions and view information about public teams they are not members of via a direct API call to /api/v4/teams/{team_id}.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-4128?

10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.5 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.14 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.14 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | 9.11.14+incompatible, 10.5.5+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250422131222-701ddc896a10 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250422131222-701ddc896a10 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250422131222-701ddc896a10 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-4128?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.5, 9.11.14, 9.11.14+incompatible or 10.5.5+incompatible.

## Is CVE-2025-4128 being exploited?

There is no known exploitation of CVE-2025-4128 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4128 and fix it if it is affected.

What it is: CVE-2025-4128 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 11 Jun 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4128 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.5
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.5
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.14
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.14
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0+incompatible; fixed in 9.11.14+incompatible, 10.5.5+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250422131222-701ddc896a10
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250422131222-701ddc896a10
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250422131222-701ddc896a10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4128/ (Markdown: https://insights.sbomify.com/CVE-2025-4128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4128
- OSV: https://osv.dev/vulnerability/CVE-2025-4128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4128/
Summaries are generated and may contain mistakes; the official description above is the record.
