{"answers":{"affected":"3 open source packages ship an affected version, including libpython, python and python-min.","exploited":"There is no known exploitation of CVE-2025-4138 in the wild and no public exploit code.","fix":"Upgrade libpython to a fixed version for your release line: 3.9.23, 3.10.18, 3.11.13 or 3.12.11.","what":"CVE-2025-4138 is a high-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-4138 and fix it if it is affected.\n\nWhat it is: CVE-2025-4138 is a high-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-4138 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libpython (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n- python (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n- python-min (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4138/ (Markdown: https://insights.sbomify.com/CVE-2025-4138/index.md)","id":"CVE-2025-4138","markdown":"https://insights.sbomify.com/CVE-2025-4138/index.md","name":"CVE-2025-4138","record":{"aliases":["ALPINE-CVE-2025-4138","AZL-62322","BELL-CVE-2025-4138","BIT-libpython-2025-4138","BIT-python-2025-4138","BIT-python-min-2025-4138","CLEANSTART-2026-YD82249","DEBIAN-CVE-2025-4138","ECHO-5b27-f272-cf44","GHSA-4g4g-fqw4-prp2","MINI-5hmj-4xxq-vv53","MINI-82wx-m8p4-65x8","MINI-jf23-mhq6-mg9j","MINI-w4p8-v8gg-27cq","PSF-2025-6","UBUNTU-CVE-2025-4138"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python tarfile module","requires_auth":"none","summary":"Attackers can bypass extraction filters to create symlinks outside the target directory, potentially modifying files or bypassing security controls.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"PSF","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Allows the extraction filter to be ignored, allowing symlink targets to point outside the destination directory, and the modification of some file metadata.\n\nYou are affected by this vulnerability if using the tarfile module to extract untrusted tar archives using TarFile.extractall() or TarFile.extract() using the filter= parameter with a value of \"data\" or \"tar\". See the tarfile  extraction filters documentation https://docs.python.org/3/library/tarfile.html#tarfile-extraction-filter  for more information.\n\nNote that for Python 3.14 or later the default value of filter= changed from \"no filtering\" to `\"data\", so if you are relying on this new default behavior then your usage is also affected.\n\nNote that none of these vulnerabilities significantly affect the installation of source distributions which are tar archives as source distributions already allow arbitrary code execution during the build process. However when evaluating source distributions it's important to avoid installing source distributions with suspicious links.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-02-15","github_poc":5,"max_poc_stars":16,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-02-15T08:28:28Z","kind":"github_poc","ref":"https://github.com/DesertDemons/CVE-2025-4138-4517-POC","stars":16,"title":"CVE-2025-4138 / CVE-2025-4517 — Python tarfile PATH_MAX Symlink Filter Bypass "},{"date":"2026-02-15T21:59:58Z","kind":"github_poc","ref":"https://github.com/thefizzyfish/CVE-2025-4138_tarfile_filter_bypass","stars":4,"title":"CVE-2025-4138 - Python Arbitrary file write outside extraction directory"},{"date":"2026-02-16T13:31:00Z","kind":"github_poc","ref":"https://github.com/kyakei/CVE-2025-4138-poc","stars":1,"title":"A Python script to generate a malicious tar archive that exploits CVE-2025-4138 / CVE-2025-4517."},{"date":"2026-02-16T17:05:37Z","kind":"github_poc","ref":"https://github.com/localh0ste/CVE-2025-4138","stars":0,"title":"Tarfile module directory traversal vulnerability ( with overflow crossed Directory ) --\u003e Lead to Privilege escalation "},{"date":"2026-02-22T12:10:45Z","kind":"github_poc","ref":"https://github.com/d3vn0mi/CVE-2025-4138-POC","stars":0,"title":"Python PoC for CVE-2025-4138, a path traversal in Python's tarfile module abusing symlink chains to bypass PATH_MAX for arbitrary file write"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Bypassing extraction filter to create symlinks to arbitrary targets outside extraction directory","id":"CVE-2025-4138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":12,"next":{"headline":"Netgear EX6120 fwAcosCgiInbound buffer overflow","id":"CVE-2025-4139"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"libpython","purl":"pkg:bitnami/libpython","source":"BIT-libpython-2025-4138"},{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"python","purl":"pkg:bitnami/python","source":"BIT-python-2025-4138"},{"ecosystem":"Bitnami","fixed":["3.9.23","3.10.18","3.11.13","3.12.11","3.13.4"],"introduced":["0","3.10.0","3.11.0","3.12.0","3.13.0"],"last_affected":[],"package":"python-min","purl":"pkg:bitnami/python-min","source":"BIT-python-min-2025-4138"}],"prev":{"headline":"Weitong Mall Sale Endpoint improper authorization","id":"CVE-2025-4136"},"products":["CPython"],"published":"2025-06-03","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-31","vendors":["Python Software Foundation"]},"summary":"Attackers can bypass extraction filters to create symlinks outside the target directory, potentially modifying files or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2025-4138/"}