# CVE-2025-41410: Slack import bypasses email verification for team access controls

> Attackers can bypass email verification during Slack imports to create verified accounts with arbitrary domains, circumventing team access restrictions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-3q4q-wqm6-hvf3, GO-2025-4029

## What is CVE-2025-41410?

CVE-2025-41410 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.10.x <= 10.10.2, 10.5.x <= 10.5.10, 10.11.x <= 10.11.2 fail to validate email ownership during Slack import process which allows attackers to create verified user accounts with arbitrary email domains via malicious Slack import data to bypass email-based team access restrictions

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-41410?

12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.11 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.11 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | 10.5.11+incompatible, 10.10.3+incompatible, 10.11.3+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250822083415-01b95392a450 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250822083415-01b95392a450 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-41410?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.3, 10.11.3, 10.5.11 or 10.5.11+incompatible.

## Is CVE-2025-41410 being exploited?

There is no known exploitation of CVE-2025-41410 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41410 and fix it if it is affected.

What it is: CVE-2025-41410 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-41410 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.3
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.3
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.3
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.3
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.11
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.11
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0+incompatible; fixed in 10.5.11+incompatible, 10.10.3+incompatible, 10.11.3+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250822083415-01b95392a450
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250822083415-01b95392a450

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41410/ (Markdown: https://insights.sbomify.com/CVE-2025-41410/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41410
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41410
- OSV: https://osv.dev/vulnerability/CVE-2025-41410

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41410/
Summaries are generated and may contain mistakes; the official description above is the record.
