# CVE-2025-41423: Unauthorized Playbooks Post Deletion in Mattermost Playbooks Plugin

> Attackers can delete Playbooks bot posts without authorization due to missing permission checks in the Mattermost Playbooks plugin API.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-fr22-5377-f3p7, GO-2025-3644

## What is CVE-2025-41423?

CVE-2025-41423 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.10 fail to properly validate permissions for the API endpoint /plugins/playbooks/api/v0/signal/keywords/ignore-thread, allowing any user or attacker to delete posts containing actions created by the Playbooks bot, even without channel access or appropriate permissions.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-41423?

21 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-plugin-playbooks and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.4.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 10.5.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.11.0 | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | All versions | 1.41.0 |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | From 2.0.0 | None |
| `github.com/mattermost/mattermost-plugin-playbooks` | Go | From 2.0.0 | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.4.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0+incompatible | None |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | None |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-41423?

Upgrade github.com/mattermost/mattermost/server/v8 to 8.0.0-20250218121836-2b5275d87136 or later.

## Is CVE-2025-41423 being exploited?

There is no known exploitation of CVE-2025-41423 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41423 and fix it if it is affected.

What it is: CVE-2025-41423 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-41423 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250218121836-2b5275d87136
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.4.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 10.5.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.11.0; no fix listed
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-plugin-playbooks (Go): affected all versions; fixed in 1.41.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41423/ (Markdown: https://insights.sbomify.com/CVE-2025-41423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41423
- OSV: https://osv.dev/vulnerability/CVE-2025-41423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41423/
Summaries are generated and may contain mistakes; the official description above is the record.
