# CVE-2025-4143: Missing validation of redirect_uri on authorize endpoint

> Attackers can steal OAuth credentials via open redirect if the application auto-approves previously authorized clients, leading to account takeover.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 May 2025
- **Updated:** 1 May 2025
- **Also known as:** GHSA-4pc9-x2fx-p7vj

## What is CVE-2025-4143?

CVE-2025-4143 is a medium-severity vulnerability in cloudflare:workers-oauth-provider, published on 1 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The OAuth implementation in workers-oauth-provider that is part of  MCP framework https://github.com/cloudflare/workers-mcp , did not correctly validate that redirect_uri was on the allowed list of redirect URIs for the given client registration.

Fixed in:  https://github.com/cloudflare/workers-oauth-provider/pull/26 https://github.com/cloudflare/workers-oauth-provider/pull/26 

Impact:

 

Under certain circumstances (see below), if a victim had previously authorized with a server built on workers-oath-provider, and an attacker could later trick the victim into visiting a malicious web site, then attacker could potentially steal the victim's credentials to the same OAuth server and subsequently impersonate them.

In order for the attack to be possible, the OAuth server's authorized callback must be designed to auto-approve authorizations that appear to come from an OAuth client that the victim has authorized previously. The authorization flow is not implemented by workers-oauth-provider; it is up to the application built on top to decide whether to implement such automatic re-authorization. However, many applications do implement such logic.

Note: It is a basic, well-known requirement that OAuth servers should verify that the redirect URI is among the allowed list for the client, both during the authorization flow and subsequently when exchanging the authorization code for an access token. workers-oauth-provider implemented only the latter check, not the former. Unfortunately, the former is the much more important check. Readers who are familiar with OAuth may recognize that failing to check redirect URIs against the allowed list is a well-known, basic mistake, covered extensively in the RFC and elsewhere. The author of this library would like everyone to know that he was, in fact, well-aware of this requirement, thought about it a lot while designing the library, and then, somehow, forgot to actually make sure the check was in the code. That is, it's not that he didn't know what he was doing, it's that he knew what he was doing but flubbed it.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2025-4143?

2 open source packages ship an affected version, including @cloudflare/workers-oauth-provider. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cloudflare/workers-oauth-provider` | npm | All versions | 0.0.5 |
| `@cloudflare/workers-oauth-provider` | npm | All versions | 0.0.5 |

Products: Cloudflare Workers-Oauth-Provider.

## How do I fix CVE-2025-4143?

Upgrade @cloudflare/workers-oauth-provider to 0.0.5 or later.

## Is CVE-2025-4143 being exploited?

There is no known exploitation of CVE-2025-4143 in the wild and no public exploit code.

## Other vulnerabilities in cloudflare:workers-oauth-provider

- [CVE-2025-4144](https://insights.sbomify.com/CVE-2025-4144/): PKCE bypass via downgrade attack (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4143 and fix it if it is affected.

What it is: CVE-2025-4143 is a medium-severity vulnerability in cloudflare:workers-oauth-provider, published on 1 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4143 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cloudflare/workers-oauth-provider (npm): affected all versions; fixed in 0.0.5
- @cloudflare/workers-oauth-provider (npm): affected all versions; fixed in 0.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4143/ (Markdown: https://insights.sbomify.com/CVE-2025-4143/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4143
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4143
- OSV: https://osv.dev/vulnerability/CVE-2025-4143

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4143/
Summaries are generated and may contain mistakes; the official description above is the record.
