{"answers":{"affected":"2 open source packages ship an affected version, including @cloudflare/workers-oauth-provider. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-4144 in the wild and no public exploit code.","fix":"Upgrade @cloudflare/workers-oauth-provider to 0.0.5 or later.","what":"CVE-2025-4144 is a medium-severity vulnerability in cloudflare:workers-oauth-provider, published on 1 May 2025."},"fix_prompt":"Check this codebase for CVE-2025-4144 and fix it if it is affected.\n\nWhat it is: CVE-2025-4144 is a medium-severity vulnerability in cloudflare:workers-oauth-provider, published on 1 May 2025. \nExploitation: There is no known exploitation of CVE-2025-4144 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @cloudflare/workers-oauth-provider (npm): affected all versions; fixed in 0.0.5\n- @cloudflare/workers-oauth-provider (npm): affected all versions; fixed in 0.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4144/ (Markdown: https://insights.sbomify.com/CVE-2025-4144/index.md)","id":"CVE-2025-4144","markdown":"https://insights.sbomify.com/CVE-2025-4144/index.md","name":"CVE-2025-4144","record":{"aliases":["GHSA-qgp8-v765-qxx9"],"analysis":null,"analysis_generated_by":null,"assigner":"cloudflare","cpe":[{"product":"workers-oauth-provider","vendor":"cloudflare"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/U:Amber","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"PKCE was implemented in the OAuth implementation in workers-oauth-provider that is part of  MCP framework https://github.com/cloudflare/workers-mcp . However, it was found that an attacker could cause the check to be skipped.\n\nFixed in:\n\n \n\n https://github.com/cloudflare/workers-oauth-provider/pull/27 https://github.com/cloudflare/workers-oauth-provider/pull/27 \n\nImpact: \n\nPKCE is a defense-in-depth mechanism against certain kinds of attacks and was an optional extension in OAuth 2.0 which became required in the OAuth 2.1 draft. (Note that the MCP specification requires OAuth 2.1.). This bug completely bypasses PKCE protection.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PKCE bypass via downgrade attack","id":"CVE-2025-4144","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":null,"year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Netgear EX6200 sub_3D0BC buffer overflow","id":"CVE-2025-4145"},"packages":[{"ecosystem":"npm","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"@cloudflare/workers-oauth-provider","purl":null,"source":"GHSA-qgp8-v765-qxx9"},{"ecosystem":"npm","fixed":["0.0.5"],"introduced":["0"],"last_affected":[],"package":"@cloudflare/workers-oauth-provider","purl":"pkg:npm/%40cloudflare/workers-oauth-provider","source":"GHSA-qgp8-v765-qxx9"}],"prev":{"headline":"Missing validation of redirect_uri on authorize endpoint","id":"CVE-2025-4143"},"products":["cloudflare:workers-oauth-provider"],"published":"2025-05-01","related":[{"cvss_score":6,"headline":"Missing validation of redirect_uri on authorize endpoint","id":"CVE-2025-4143","kev_date_added":null,"published":"2025-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-01","vendors":["cloudflare"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2025-4144/"}