# CVE-2025-41443: Guest user can discover active public channels

> Guest users can discover active public channels and metadata due to improper permission validation, exposing internal channel information.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-7cr3-38jm-6p45, GO-2025-4031

## What is CVE-2025-41443?

CVE-2025-41443 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.5.x <= 10.5.12, 10.11.x <= 10.11.2 fail to properly validate guest user permissions when accessing channel information which allows guest users to discover active public channels and their metadata via the `/api/v4/teams/{team_id}/channels/ids` endpoint

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-41443?

7 open source packages ship an affected version, including github.com/mattermost/mattermost-server and github.com/mattermost/mattermost/server/v8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | None |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.11.0 | 10.11.3 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.11 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.11 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250822090405-e8c7e7d0252b |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250822090405-e8c7e7d0252b |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-41443?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.3 or 10.5.11.

## Is CVE-2025-41443 being exploited?

There is no known exploitation of CVE-2025-41443 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-41443 and fix it if it is affected.

What it is: CVE-2025-41443 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 16 Oct 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-41443 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.3
- github.com/mattermost/mattermost-server (Go): affected from 10.11.0; fixed in 10.11.3
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.11
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.11
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250822090405-e8c7e7d0252b
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250822090405-e8c7e7d0252b

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-41443/ (Markdown: https://insights.sbomify.com/CVE-2025-41443/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-41443
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-41443
- OSV: https://osv.dev/vulnerability/CVE-2025-41443

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-41443/
Summaries are generated and may contain mistakes; the official description above is the record.
