CVE-2025-4166 Vault May Include Sensitive Data in Error Logs When Using the KV v2 Plugin
Attackers can expose sensitive data in logs by submitting malformed payloads to the KV v2 plugin, requiring an upgrade to Vault.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-4166?
CVE-2025-4166 is a medium-severity vulnerability in Hashicorp Vault, published on 2 May 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.
Weakness: CWE-209
Which versions are affected by CVE-2025-4166?
5 open source packages ship an affected version, including github.com/hashicorp/vault, openbao and vault. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | From 0.3.0 | 1.19.3 |
github.com/hashicorp/vault Go | From 0.3.0 | 1.19.3 |
github.com/hashicorp/vault Go | From 0.3.0 | 1.19.3 |
openbao Bitnami | All versions | 2.2.2 |
vault Bitnami | From 0.3.0 | 1.19.3 |
Linux distribution packages (1)
openbao openSUSE:Tumbleweed | All versions | 2.2.2-1.1 |
Products include Hashicorp Vault, Openbao Openbao.
How do I fix CVE-2025-4166?
Upgrade github.com/hashicorp/vault to 1.19.3 or later.
Is CVE-2025-4166 being exploited?
There is no known exploitation of CVE-2025-4166 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-openbao-2025-4166, BIT-vault-2025-4166, GHSA-gcqf-f89c-68hv, GO-2025-3663, openSUSE-SU-2025:15186-1.