# CVE-2025-4166: Vault May Include Sensitive Data in Error Logs When Using the KV v2 Plugin

> Attackers can expose sensitive data in logs by submitting malformed payloads to the KV v2 plugin, requiring an upgrade to Vault.

- **Severity:** Medium 4.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 May 2025
- **Updated:** 8 May 2025
- **Also known as:** BIT-openbao-2025-4166, BIT-vault-2025-4166, GHSA-gcqf-f89c-68hv, GO-2025-3663, openSUSE-SU-2025:15186-1

## What is CVE-2025-4166?

CVE-2025-4166 is a medium-severity vulnerability in Hashicorp Vault, published on 2 May 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Vault Community and Vault Enterprise Key/Value (kv) Version 2 plugin may unintentionally expose sensitive information in server and audit logs when users submit malformed payloads during secret creation or update operations via the Vault REST API. This vulnerability, identified as CVE-2025-4166, is fixed in Vault Community 1.19.3 and Vault Enterprise 1.19.3, 1.18.9, 1.17.16, 1.16.20.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2025-4166?

5 open source packages ship an affected version, including github.com/hashicorp/vault, openbao and vault. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 0.3.0 | 1.19.3 |
| `github.com/hashicorp/vault` | Go | From 0.3.0 | 1.19.3 |
| `github.com/hashicorp/vault` | Go | From 0.3.0 | 1.19.3 |
| `openbao` | Bitnami | All versions | 2.2.2 |
| `vault` | Bitnami | From 0.3.0 | 1.19.3 |
| `openbao` | openSUSE:Tumbleweed | All versions | 2.2.2-1.1 |

Products: Hashicorp Vault, Openbao Openbao.

## How do I fix CVE-2025-4166?

Upgrade github.com/hashicorp/vault to 1.19.3 or later.

## Is CVE-2025-4166 being exploited?

There is no known exploitation of CVE-2025-4166 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4166 and fix it if it is affected.

What it is: CVE-2025-4166 is a medium-severity vulnerability in Hashicorp Vault, published on 2 May 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4166 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 0.3.0; fixed in 1.19.3
- github.com/hashicorp/vault (Go): affected from 0.3.0; fixed in 1.19.3
- github.com/hashicorp/vault (Go): affected from 0.3.0; fixed in 1.19.3
- openbao (Bitnami): affected all versions; fixed in 2.2.2
- vault (Bitnami): affected from 0.3.0; fixed in 1.19.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4166/ (Markdown: https://insights.sbomify.com/CVE-2025-4166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4166
- OSV: https://osv.dev/vulnerability/CVE-2025-4166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4166/
Summaries are generated and may contain mistakes; the official description above is the record.
