# CVE-2025-4179: Flynax Bridge <= 2.2.0 - Unauthenticated Limited Privilege Escalation

> Unauthenticated attackers can register as authors due to missing capability checks in the Flynax Bridge WordPress plugin.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 May 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-7cm5-6vm2-x739

## What is CVE-2025-4179?

CVE-2025-4179 is a high-severity vulnerability in v1rustyle Flynax Bridge, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Flynax Bridge plugin for WordPress is vulnerable to limited Privilege Escalation due to a missing capability check on the registerUser() function in all versions up to, and including, 2.2.0. This makes it possible for unauthenticated attackers to register new user accounts as authors.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-4179?

It affects 1 product.


Products: Flynax Flynax Bridge.

## How do I fix CVE-2025-4179?

No fix has been published for CVE-2025-4179 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-4179 being exploited?

There is no known exploitation of CVE-2025-4179 in the wild and no public exploit code.

## Other vulnerabilities in v1rustyle Flynax Bridge

- [CVE-2025-3603](https://insights.sbomify.com/CVE-2025-3603/): Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Password Update (critical 9.8)
- [CVE-2025-3604](https://insights.sbomify.com/CVE-2025-3604/): Flynax Bridge <= 2.2.0 - Unauthenticated Privilege Escalation via Account Takeover (critical 9.8)
- [CVE-2025-4177](https://insights.sbomify.com/CVE-2025-4177/): Flynax Bridge <= 2.2.0 - Unauthenticated Arbitrary User Deletion (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4179 and fix it if it is affected.

What it is: CVE-2025-4179 is a high-severity vulnerability in v1rustyle Flynax Bridge, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4179 in the wild and no public exploit code.

Affected product: v1rustyle Flynax Bridge. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4179/ (Markdown: https://insights.sbomify.com/CVE-2025-4179/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4179
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4179
- OSV: https://osv.dev/vulnerability/CVE-2025-4179

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4179/
Summaries are generated and may contain mistakes; the official description above is the record.
