# CVE-2025-4210: Casdoor SCIM User Creation Endpoint scim.go HandleScim authorization

> Attackers can bypass authorization checks in the SCIM user creation endpoint to create unauthorized users, requiring an upgrade to Casdoor.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2025
- **Updated:** 2 May 2025
- **Also known as:** GHSA-8w8f-h4cm-c4pg, GO-2025-3661

## What is CVE-2025-4210?

CVE-2025-4210 is a medium-severity missing authorization vulnerability in Casdoor, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability classified as critical was found in Casdoor up to 1.811.0. This vulnerability affects the function HandleScim of the file controllers/scim.go of the component SCIM User Creation Endpoint. The manipulation leads to authorization bypass. The attack can be initiated remotely. Upgrading to version 1.812.0 is able to address this issue. The name of the patch is 3d12ac8dc2282369296c3386815c00a06c6a92fe. It is recommended to upgrade the affected component.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-4210?

3 open source packages ship an affected version, including github.com/casdoor/casdoor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/casdoor/casdoor` | Go | All versions | None |
| `github.com/casdoor/casdoor` | Go | All versions | 1.812.0 |
| `github.com/casdoor/casdoor` | Go | All versions | 1.812.0 |

## How do I fix CVE-2025-4210?

Upgrade github.com/casdoor/casdoor to 1.812.0 or later.

## Is CVE-2025-4210 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4210 exists.

Public exploit code:

- Casdoor - Authorization Bypass (nuclei): http/cves/2025/CVE-2025-4210.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4210 and fix it if it is affected.

What it is: CVE-2025-4210 is a medium-severity missing authorization vulnerability in Casdoor, published on 2 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4210 exists.

Affected packages and fixed versions:
- github.com/casdoor/casdoor (Go): affected all versions; no fix listed
- github.com/casdoor/casdoor (Go): affected all versions; fixed in 1.812.0
- github.com/casdoor/casdoor (Go): affected all versions; fixed in 1.812.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4210/ (Markdown: https://insights.sbomify.com/CVE-2025-4210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4210
- OSV: https://osv.dev/vulnerability/CVE-2025-4210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4210/
Summaries are generated and may contain mistakes; the official description above is the record.
