{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-4211 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-4211 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-4211 is a high-severity path traversal vulnerability in Qt, published on 16 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-4211 and fix it if it is affected.\n\nWhat it is: CVE-2025-4211 is a high-severity path traversal vulnerability in Qt, published on 16 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-4211 in the wild and no public exploit code.\n\nAffected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-4211/ (Markdown: https://insights.sbomify.com/CVE-2025-4211/index.md)","id":"CVE-2025-4211","markdown":"https://insights.sbomify.com/CVE-2025-4211/index.md","name":"CVE-2025-4211","record":{"aliases":["GHSA-8cgq-rf3m-gjm4","UBUNTU-CVE-2025-4211"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Qt corelib module","requires_auth":"low_privilege","summary":"Attackers can exploit improper link resolution in Qt's temporary file handling on Windows to access malicious files and escalate privileges.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TQtC","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:P","version":"4.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"Improper Link Resolution Before File Access ('Link Following') vulnerability in QFileSystemEngine in the Qt corelib module on Windows which potentially allows Symlink Attacks and the use of Malicious Files. Issue originates from CVE-2024-38081. The vulnerability arises from the use of the GetTempPath API, which can be exploited by attackers to manipulate temporary file paths, potentially leading to unauthorized access and privilege escalation. The affected public API in the Qt Framework is QDir::tempPath() and anything that uses it, such as QStandardPaths with TempLocation, QTemporaryDir, and QTemporaryFile.\n\nThis issue affects all version of Qt up to and including 5.15.18, from 6.0.0 through 6.5.8, from 6.6.0 through 6.8.1. It is fixed in Qt 5.15.19, Qt 6.5.9, Qt 6.8.2, 6.9.0","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Improper Link Resolution Before File Access in QFileSystemEngine on Windows","id":"CVE-2025-4211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":0,"n_references":1,"next":{"headline":"Checkout Files Upload for WooCommerce \u003c= 2.2.1 - Unauthenticated Stored Cross-Site Scripting","id":"CVE-2025-4212"},"packages":[],"prev":{"headline":"Casdoor SCIM User Creation Endpoint scim.go HandleScim authorization","id":"CVE-2025-4210"},"products":["Qt"],"published":"2025-05-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-29","vendors":["Qt"]},"summary":"Attackers can exploit improper link resolution in Qt's temporary file handling on Windows to access malicious files and escalate privileges.","url":"https://insights.sbomify.com/CVE-2025-4211/"}