# CVE-2025-4211: Improper Link Resolution Before File Access in QFileSystemEngine on Windows

> Attackers can exploit improper link resolution in Qt's temporary file handling on Windows to access malicious files and escalate privileges.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/S:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 May 2025
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-8cgq-rf3m-gjm4, UBUNTU-CVE-2025-4211

## What is CVE-2025-4211?

CVE-2025-4211 is a high-severity path traversal vulnerability in Qt, published on 16 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper Link Resolution Before File Access ('Link Following') vulnerability in QFileSystemEngine in the Qt corelib module on Windows which potentially allows Symlink Attacks and the use of Malicious Files. Issue originates from CVE-2024-38081. The vulnerability arises from the use of the GetTempPath API, which can be exploited by attackers to manipulate temporary file paths, potentially leading to unauthorized access and privilege escalation. The affected public API in the Qt Framework is QDir::tempPath() and anything that uses it, such as QStandardPaths with TempLocation, QTemporaryDir, and QTemporaryFile.

This issue affects all version of Qt up to and including 5.15.18, from 6.0.0 through 6.5.8, from 6.6.0 through 6.8.1. It is fixed in Qt 5.15.19, Qt 6.5.9, Qt 6.8.2, 6.9.0

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-4211?


## How do I fix CVE-2025-4211?

No fix has been published for CVE-2025-4211 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-4211 being exploited?

There is no known exploitation of CVE-2025-4211 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4211 and fix it if it is affected.

What it is: CVE-2025-4211 is a high-severity path traversal vulnerability in Qt, published on 16 May 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-4211 in the wild and no public exploit code.

Affected product: Qt. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4211/ (Markdown: https://insights.sbomify.com/CVE-2025-4211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4211
- OSV: https://osv.dev/vulnerability/CVE-2025-4211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4211/
Summaries are generated and may contain mistakes; the official description above is the record.
