# CVE-2025-4215: gorhill uBlock Origin UI 1p-filters.js currentStateChanged redos

> Remote attackers can cause denial of service in uBlock Origin via inefficient regular expressions in the UI component.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 May 2025
- **Updated:** 12 Jun 2025
- **Also known as:** DEBIAN-CVE-2025-4215, DLA-4215-1, GHSA-785g-r934-c877, UBUNTU-CVE-2025-4215

## What is CVE-2025-4215?

CVE-2025-4215 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 2 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in gorhill uBlock Origin up to 1.63.3b16. It has been classified as problematic. Affected is the function currentStateChanged of the file src/js/1p-filters.js of the component UI. The manipulation leads to inefficient regular expression complexity. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.63.3b17 is able to address this issue. The patch is identified as eaedaf5b10d2f7857c6b77fbf7d4a80681d4d46c. It is recommended to upgrade the affected component.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2025-4215?

It affects 2 products.


Products: Debian Debian Linux, Ublockorigin Ublock Origin.

## How do I fix CVE-2025-4215?

Upgrade to a fixed version.

## Is CVE-2025-4215 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4215 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4215 and fix it if it is affected.

What it is: CVE-2025-4215 is a low-severity denial of service vulnerability in Debian Debian Linux, published on 2 May 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4215 exists.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4215/ (Markdown: https://insights.sbomify.com/CVE-2025-4215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4215
- OSV: https://osv.dev/vulnerability/CVE-2025-4215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4215/
Summaries are generated and may contain mistakes; the official description above is the record.
