CVE-2025-4225 Allocation of Resources Without Limits or Throttling in GitLab

Medium 5.3 Published Updated

An unauthenticated attacker can cause a denial-of-service condition for all users by sending specially crafted GraphQL requests to GitLab.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-4225?

CVE-2025-4225 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 27 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 14.1 before 18.1.5, 18.2 before 18.2.5, and 18.3 before 18.3.1 that that under certain conditions could have allowed an unauthenticated attacker to cause a denial-of-service condition affecting all users by sending specially crafted GraphQL requests.

Weakness: CWE-770

Which versions are affected by CVE-2025-4225?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.1.018.1.5, 18.2.5, 18.3.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-4225?

Upgrade gitlab to a fixed version for your release line: 18.1.5, 18.2.5 or 18.3.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-4225 being exploited?

There is no known exploitation of CVE-2025-4225 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-4225, GHSA-rq6q-w27x-f9x2, MINI-3h8r-qrx3-x52g, MINI-475j-x3cv-g4x5, MINI-cj8v-p3j8-w5fx, MINI-cm25-m2p9-hh2c and 4 more.

Is CVE-2025-4225 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free