# CVE-2025-4318: Input validation issue in AWS Amplify Studio UI component properties

> Authenticated users can execute arbitrary JavaScript code via unvalidated UI component property expressions in AWS Amplify Studio.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 May 2025
- **Updated:** 29 Jul 2026
- **Also known as:** GHSA-hf3j-86p7-mfw8

## What is CVE-2025-4318?

CVE-2025-4318 is a critical code injection vulnerability in Amazon Amplify Studio, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The AWS Amplify Studio UI component property expressions in the aws-amplify/amplify-codegen-ui package lack input validation. This could potentially allow an authenticated user who has access to create or modify components to run arbitrary JavaScript code during the component rendering and build process.

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2025-4318?

2 open source packages ship an affected version, including @aws-amplify/codegen-ui-react.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@aws-amplify/codegen-ui-react` | npm | All versions | 2.20.3 |
| `@aws-amplify/codegen-ui-react` | npm | All versions | 2.20.3 |

## How do I fix CVE-2025-4318?

Upgrade @aws-amplify/codegen-ui-react to 2.20.3 or later.

## Is CVE-2025-4318 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4318 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4318 and fix it if it is affected.

What it is: CVE-2025-4318 is a critical code injection vulnerability in Amazon Amplify Studio, published on 5 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-4318 exists.

Affected packages and fixed versions:
- @aws-amplify/codegen-ui-react (npm): affected all versions; fixed in 2.20.3
- @aws-amplify/codegen-ui-react (npm): affected all versions; fixed in 2.20.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4318/ (Markdown: https://insights.sbomify.com/CVE-2025-4318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4318
- OSV: https://osv.dev/vulnerability/CVE-2025-4318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4318/
Summaries are generated and may contain mistakes; the official description above is the record.
