# CVE-2025-4330: Extraction filter bypass for linking outside extraction directory

> Attackers can bypass extraction filters to create symlinks outside the target directory, potentially modifying files or metadata.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 4 Aug 2026
- **Also known as:** ALPINE-CVE-2025-4330, AZL-62313, BELL-CVE-2025-4330, BIT-libpython-2025-4330, BIT-python-2025-4330, BIT-python-min-2025-4330, CLEANSTART-2026-YB84757, DEBIAN-CVE-2025-4330, ECHO-530e-e36d-f428, GHSA-68pj-xrp5-vccj, MINI-fj76-hmw9-27w8, MINI-pqf4-534v-vpj3, MINI-r5w9-7rxp-3fwg, MINI-rp38-xr9j-ww7x, PSF-2025-7, UBUNTU-CVE-2025-4330

## What is CVE-2025-4330?

CVE-2025-4330 is a high-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Allows the extraction filter to be ignored, allowing symlink targets to point outside the destination directory, and the modification of some file metadata.

You are affected by this vulnerability if using the tarfile module to extract untrusted tar archives using TarFile.extractall() or TarFile.extract() using the filter= parameter with a value of "data" or "tar". See the tarfile  extraction filters documentation https://docs.python.org/3/library/tarfile.html#tarfile-extraction-filter  for more information.

Note that for Python 3.14 or later the default value of filter= changed from "no filtering" to `"data", so if you are relying on this new default behavior then your usage is also affected.

Note that none of these vulnerabilities significantly affect the installation of source distributions which are tar archives as source distributions already allow arbitrary code execution during the build process. However when evaluating source distributions it's important to avoid installing source distributions with suspicious links.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-4330?

3 open source packages ship an affected version, including libpython, python and python-min.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |
| `python` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |
| `python-min` | Bitnami | All versions | 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4 |

## How do I fix CVE-2025-4330?

Upgrade libpython to a fixed version for your release line: 3.9.23, 3.10.18, 3.11.13 or 3.12.11.

## Is CVE-2025-4330 being exploited?

There is no known exploitation of CVE-2025-4330 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4330 and fix it if it is affected.

What it is: CVE-2025-4330 is a high-severity path traversal vulnerability in CPython, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4330 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4
- python (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4
- python-min (Bitnami): affected all versions; fixed in 3.9.23, 3.10.18, 3.11.13, 3.12.11, 3.13.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4330/ (Markdown: https://insights.sbomify.com/CVE-2025-4330/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4330
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4330
- OSV: https://osv.dev/vulnerability/CVE-2025-4330

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4330/
Summaries are generated and may contain mistakes; the official description above is the record.
