# CVE-2025-4370: Brizy <= 2.6.20 - Missing Authorization to Unauthenticated Limited File Upload

> Unauthenticated attackers can upload .TXT files to the server due to missing authorization and path validation in the Brizy Page Builder plugin.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Jul 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-p6h5-x466-mj5p

## What is CVE-2025-4370?

CVE-2025-4370 is a medium-severity missing authorization vulnerability in themefusecom Brizy – Page Builder, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Brizy – Page Builder plugin for WordPress is vulnerable to limited file uploads due to missing authorization on process_external_asset_urls function as well as missing path validation in store_file function in all versions up to, and including, 2.6.20. This makes it possible for unauthenticated attackers to upload .TXT files on the affected site's server.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-4370?

It affects 1 product.


Products: Brizy Brizy.

## How do I fix CVE-2025-4370?

No fix has been published for CVE-2025-4370 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-4370 being exploited?

There is no known exploitation of CVE-2025-4370 in the wild and no public exploit code.

## Other vulnerabilities in themefusecom Brizy – Page Builder

- [CVE-2024-10960](https://insights.sbomify.com/CVE-2024-10960/): Brizy – Page Builder <= 2.6.4 - Authenticated (Contributor+) Arbitrary File Upload via storeUploads (critical 9.9)
- [CVE-2024-3242](https://insights.sbomify.com/CVE-2024-3242/): Brizy – Page Builder <= 2.4.44 - Authenticated (Contributor+) Arbitrary File Upload (high 8.8)
- [CVE-2024-1311](https://insights.sbomify.com/CVE-2024-1311/): Brizy – Page Builder <= 2.4.40 - Authenticated (Contributor+) Arbitrary File Upload (high 8.8)
- [CVE-2024-3667](https://insights.sbomify.com/CVE-2024-3667/): Brizy – Page Builder <= 2.4.43 - Authenticated (Contributor+) Store Cross-Site Scripting via Widget Link To URL (high 7.4)
- [CVE-2020-36714](https://insights.sbomify.com/CVE-2020-36714/): Brizy < 1.0.126 - Authorization Bypass to Settings Updates (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-4370 and fix it if it is affected.

What it is: CVE-2025-4370 is a medium-severity missing authorization vulnerability in themefusecom Brizy – Page Builder, published on 29 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-4370 in the wild and no public exploit code.

Affected product: themefusecom Brizy – Page Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-4370/ (Markdown: https://insights.sbomify.com/CVE-2025-4370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-4370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-4370
- OSV: https://osv.dev/vulnerability/CVE-2025-4370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-4370/
Summaries are generated and may contain mistakes; the official description above is the record.
