{"answers":{"affected":"2 open source packages ship an affected version, including pear/http_request2.","exploited":"There is no known exploitation of CVE-2025-43717 in the wild and no public exploit code.","fix":"Upgrade pear/http_request2 to 2.7.0 or later.","what":"CVE-2025-43717 is a medium-severity cross-site scripting vulnerability in avb HTTP_Request2, published on 17 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-43717 and fix it if it is affected.\n\nWhat it is: CVE-2025-43717 is a medium-severity cross-site scripting vulnerability in avb HTTP_Request2, published on 17 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-43717 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pear/http_request2 (Packagist): affected all versions; fixed in 2.7.0\n- pear/http_request2 (Packagist): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-43717/ (Markdown: https://insights.sbomify.com/CVE-2025-43717/index.md)","id":"CVE-2025-43717","markdown":"https://insights.sbomify.com/CVE-2025-43717/index.md","name":"CVE-2025-43717","record":{"aliases":["GHSA-w7gh-f2fm-9q8r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTTP library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the test files of the PEAR HTTP_Request2 library.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-531","name":"Inclusion of Sensitive Information in Test Code"}],"description":"In PEAR HTTP_Request2 before 2.7.0, multiple files in the tests directory, notably tests/_network/getparameters.php and tests/_network/postparameters.php, reflect any GET or POST parameters, leading to XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PEAR HTTP_Request2 vulnerable to Cross-site Scripting","id":"CVE-2025-43717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"Denial of service in Poppler","id":"CVE-2025-43718"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"pear/http_request2","purl":null,"source":"GHSA-w7gh-f2fm-9q8r"},{"ecosystem":"Packagist","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"pear/http_request2","purl":"pkg:composer/pear/http_request2","source":"GHSA-w7gh-f2fm-9q8r"}],"prev":{"headline":"Path traversal in LANDesk Management Suite","id":"CVE-2025-43716"},"products":["HTTP_Request2"],"published":"2025-04-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["avb"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the test files of the PEAR HTTP_Request2 library.","url":"https://insights.sbomify.com/CVE-2025-43717/"}