# CVE-2025-43717: PEAR HTTP_Request2 vulnerable to Cross-site Scripting

> An attacker can execute arbitrary scripts in the victim's browser via reflected XSS in the test files of the PEAR HTTP_Request2 library.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2025
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-w7gh-f2fm-9q8r

## What is CVE-2025-43717?

CVE-2025-43717 is a medium-severity cross-site scripting vulnerability in avb HTTP_Request2, published on 17 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PEAR HTTP_Request2 before 2.7.0, multiple files in the tests directory, notably tests/_network/getparameters.php and tests/_network/postparameters.php, reflect any GET or POST parameters, leading to XSS.

Weakness: CWE-531 (Inclusion of Sensitive Information in Test Code)

## Which versions are affected by CVE-2025-43717?

2 open source packages ship an affected version, including pear/http_request2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/http_request2` | Packagist | All versions | 2.7.0 |
| `pear/http_request2` | Packagist | All versions | 2.7.0 |

## How do I fix CVE-2025-43717?

Upgrade pear/http_request2 to 2.7.0 or later.

## Is CVE-2025-43717 being exploited?

There is no known exploitation of CVE-2025-43717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43717 and fix it if it is affected.

What it is: CVE-2025-43717 is a medium-severity cross-site scripting vulnerability in avb HTTP_Request2, published on 17 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43717 in the wild and no public exploit code.

Affected packages and fixed versions:
- pear/http_request2 (Packagist): affected all versions; fixed in 2.7.0
- pear/http_request2 (Packagist): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43717/ (Markdown: https://insights.sbomify.com/CVE-2025-43717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43717
- OSV: https://osv.dev/vulnerability/CVE-2025-43717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43717/
Summaries are generated and may contain mistakes; the official description above is the record.
