# CVE-2025-43732: Liferay Portal Vulnerable to Insecure Direct Object Reference

> An organization administrator can access user lists from other organizations by manipulating the groupId parameter, leading to unauthorized data disclosure.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-v6xr-v2qg-h22h

## What is CVE-2025-43732?

CVE-2025-43732 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 18 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Liferay Portal 7.4.0 through 7.4.3.132, and Liferay DXP 2025.Q1.0 through 2025.Q1.10, 2024.Q4.0 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.13, 2024.Q2.1 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.17 and 7.4 GA through update 92 is vulnerable to Insecure Direct Object Reference (IDOR) in the groupId parameter of the _com_liferay_roles_selector_web_portlet_RolesSelectorPortlet_groupId. When an organization administrator modifies this parameter id value, they can gain unauthorized access to user lists from other organizations.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-43732?

2 open source packages ship an affected version, including com.liferay:com.liferay.roles.selector.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.roles.selector.web` | Maven | All versions | 5.0.32 |
| `com.liferay:com.liferay.roles.selector.web` | Maven | All versions | 5.0.32 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43732?

Upgrade com.liferay:com.liferay.roles.selector.web to 5.0.32 or later.

## Is CVE-2025-43732 being exploited?

There is no known exploitation of CVE-2025-43732 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43732 and fix it if it is affected.

What it is: CVE-2025-43732 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 18 Aug 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43732 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.roles.selector.web (Maven): affected all versions; fixed in 5.0.32
- com.liferay:com.liferay.roles.selector.web (Maven): affected all versions; fixed in 5.0.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43732/ (Markdown: https://insights.sbomify.com/CVE-2025-43732/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43732
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43732
- OSV: https://osv.dev/vulnerability/CVE-2025-43732

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43732/
Summaries are generated and may contain mistakes; the official description above is the record.
