# CVE-2025-43733: Liferay Portal Vulnerable to Cross-Site Scripting

> Remote authenticated attackers can inject JavaScript via page names, leading to script execution in victim browsers on the document usage view.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-vhcr-hgc8-29qr

## What is CVE-2025-43733?

CVE-2025-43733 is a low-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A reflected cross-site scripting (XSS) vulnerability in the Liferay Portal 7.4.3.132, and Liferay DXP 2025.Q1.0 through 2025.Q1.7 allows a remote authenticated attacker to inject JavaScript code via the content page's name field. This malicious payload is then reflected and executed within the user's browser when viewing the "document View Usages" page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43733?

2 open source packages ship an affected version, including com.liferay:com.liferay.layout.taglib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.layout.taglib` | Maven | All versions | 17.0.0 |
| `com.liferay:com.liferay.layout.taglib` | Maven | All versions | 17.0.0 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43733?

Upgrade com.liferay:com.liferay.layout.taglib to 17.0.0 or later.

## Is CVE-2025-43733 being exploited?

There is no known exploitation of CVE-2025-43733 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43733 and fix it if it is affected.

What it is: CVE-2025-43733 is a low-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 18 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43733 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.layout.taglib (Maven): affected all versions; fixed in 17.0.0
- com.liferay:com.liferay.layout.taglib (Maven): affected all versions; fixed in 17.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43733/ (Markdown: https://insights.sbomify.com/CVE-2025-43733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43733
- OSV: https://osv.dev/vulnerability/CVE-2025-43733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43733/
Summaries are generated and may contain mistakes; the official description above is the record.
