# CVE-2025-43753: Liferay Portal Reflected Cross-Site Scripting Vulnerability via Form Container

> Remote authenticated users can inject JavaScript into the embedded message field, enabling cross-site scripting attacks against other users.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2025
- **Updated:** 22 Aug 2025
- **Also known as:** GHSA-r367-q549-pgr5

## What is CVE-2025-43753?

CVE-2025-43753 is a low-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A reflected cross-site scripting (XSS) vulnerability in the Liferay Portal 7.4.3.32 through 7.4.3.132, and Liferay DXP 2025.Q1.0 through 2025.Q1.7, 2024.Q4.0 through 2024.Q4.7, 2024.Q3.1 through 2024.Q3.13, 2024.Q2.1 through 2024.Q2.13, 2024.Q1.1 through 2024.Q1.16 and 7.4 update 32 through update 92 allows an remote authenticated user to inject JavaScript into the embedded message field from the form container.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43753?

2 open source packages ship an affected version, including com.liferay:com.liferay.layout.taglib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.layout.taglib` | Maven | All versions | 16.1.32 |
| `com.liferay:com.liferay.layout.taglib` | Maven | All versions | 16.1.32 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43753?

Upgrade com.liferay:com.liferay.layout.taglib to 16.1.32 or later.

## Is CVE-2025-43753 being exploited?

There is no known exploitation of CVE-2025-43753 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43753 and fix it if it is affected.

What it is: CVE-2025-43753 is a low-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 21 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43753 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.layout.taglib (Maven): affected all versions; fixed in 16.1.32
- com.liferay:com.liferay.layout.taglib (Maven): affected all versions; fixed in 16.1.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43753/ (Markdown: https://insights.sbomify.com/CVE-2025-43753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43753
- OSV: https://osv.dev/vulnerability/CVE-2025-43753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43753/
Summaries are generated and may contain mistakes; the official description above is the record.
