# CVE-2025-43775: Liferay Portal is vulnerable to XSS attacks via its remote app title field

> Remote attackers can inject arbitrary web script or HTML via the remote app title field in Liferay Portal, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-88g3-pv3w-5wmr

## What is CVE-2025-43775?

CVE-2025-43775 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 9 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Stored cross-site scripting (XSS) vulnerability in Liferay Portal 7.4.0 through 7.4.3.128, and Liferay DXP 2024.Q3.0 through 2024.Q3.5, 2024.Q2.0 through 2024.Q2.12, 2024.Q1.1 through 2024.Q1.12, and 7.4 GA through update 92 allows remote attackers to inject arbitrary web script or HTML via remote app title field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43775?

2 open source packages ship an affected version, including com.liferay:com.liferay.client.extension.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.client.extension.web` | Maven | From 1.0.71 | 2.0.27 |
| `com.liferay:com.liferay.client.extension.web` | Maven | From 1.0.71 | 2.0.27 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43775?

Upgrade com.liferay:com.liferay.client.extension.web to 2.0.27 or later.

## Is CVE-2025-43775 being exploited?

There is no known exploitation of CVE-2025-43775 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43775 and fix it if it is affected.

What it is: CVE-2025-43775 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 9 Sep 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43775 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.client.extension.web (Maven): affected from 1.0.71; fixed in 2.0.27
- com.liferay:com.liferay.client.extension.web (Maven): affected from 1.0.71; fixed in 2.0.27

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43775/ (Markdown: https://insights.sbomify.com/CVE-2025-43775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43775
- OSV: https://osv.dev/vulnerability/CVE-2025-43775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43775/
Summaries are generated and may contain mistakes; the official description above is the record.
