# CVE-2025-43777: Liferay Portal exposes 500 status when attempting login with a deleted client secret

> Liferay Portal exposes internal server error details in login responses when using a deleted client secret, potentially aiding attackers in reconnaissance.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2025
- **Updated:** 9 Sep 2025
- **Also known as:** GHSA-9vwq-j6gq-w9xh

## What is CVE-2025-43777?

CVE-2025-43777 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Liferay Portal  7.4.0 through 7.4.3.132, and Liferay DXP 2025.Q2.0 through 2025.Q2.9, 2025.Q1.0 through 2025.Q1.16, 2024.Q4.0 through 2024.Q4.7, 2024.Q3.0 through 2024.Q3.13, 2024.Q2.0 through 2024.Q2.13 and 2024.Q1.1 through 2024.Q1.19 exposes "Internal Server Error" in the response body when a login attempt is made with a deleted Client Secret.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2025-43777?

2 open source packages ship an affected version, including com.liferay:com.liferay.portal.security.sso.openid.connect.impl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.portal.security.sso.openid.connect.impl` | Maven | From 6.0.4 | 7.0.48 |
| `com.liferay:com.liferay.portal.security.sso.openid.connect.impl` | Maven | From 6.0.4 | 7.0.48 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43777?

Upgrade com.liferay:com.liferay.portal.security.sso.openid.connect.impl to 7.0.48 or later.

## Is CVE-2025-43777 being exploited?

There is no known exploitation of CVE-2025-43777 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43777 and fix it if it is affected.

What it is: CVE-2025-43777 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 9 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43777 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.portal.security.sso.openid.connect.impl (Maven): affected from 6.0.4; fixed in 7.0.48
- com.liferay:com.liferay.portal.security.sso.openid.connect.impl (Maven): affected from 6.0.4; fixed in 7.0.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43777/ (Markdown: https://insights.sbomify.com/CVE-2025-43777/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43777
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43777
- OSV: https://osv.dev/vulnerability/CVE-2025-43777

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43777/
Summaries are generated and may contain mistakes; the official description above is the record.
