# CVE-2025-43782: Liferay Portal API Allows Authenticated Users to Access Workflow Definitions by Name

> Authenticated attackers can access workflow definitions by name via the API due to missing authorization checks in Liferay Portal.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2025
- **Updated:** 11 Sep 2025
- **Also known as:** GHSA-wr8m-5h2p-4432

## What is CVE-2025-43782?

CVE-2025-43782 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 11 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insecure Direct Object Reference (IDOR) vulnerability in Liferay Portal 7.4.0 through 7.4.3.124, and Liferay DXP 2024.Q2.0 through 2024.Q2.7, 2024.Q1.1 through 2024.Q1.12, and 7.4 GA through update 92 allows remote authenticated users to access a workflow definition by name via the API

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-43782?

2 open source packages ship an affected version, including com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl` | Maven | From 5.0.1 | 5.0.48 |
| `com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl` | Maven | From 5.0.1 | 5.0.48 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43782?

Upgrade com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl to 5.0.48 or later.

## Is CVE-2025-43782 being exploited?

There is no known exploitation of CVE-2025-43782 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43782 and fix it if it is affected.

What it is: CVE-2025-43782 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 11 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43782 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl (Maven): affected from 5.0.1; fixed in 5.0.48
- com.liferay:com.liferay.portal.workflow.kaleo.runtime.integration.impl (Maven): affected from 5.0.1; fixed in 5.0.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43782/ (Markdown: https://insights.sbomify.com/CVE-2025-43782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43782
- OSV: https://osv.dev/vulnerability/CVE-2025-43782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43782/
Summaries are generated and may contain mistakes; the official description above is the record.
