# CVE-2025-43787: Liferay Portal's selection modal is vulnerable to XSS

> Remote authenticated attackers can inject JavaScript via organization site names, leading to stored XSS and potential session hijacking.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Sep 2025
- **Updated:** 12 Sep 2025
- **Also known as:** GHSA-g8fh-pfw3-8rmr

## What is CVE-2025-43787?

CVE-2025-43787 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 12 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A Stored cross-site scripting vulnerability in the Liferay Portal  7.4.0 through 7.4.3.132, and Liferay DXP 2025.Q3.0, 2025.Q2.0 through 2025.Q2.12, 2025.Q1.0 through 2025.Q1.17, 2024.Q4.0 through 2024.Q4.7, 2024.Q3.0 through 2024.Q3.13, 2024.Q2.0 through 2024.Q2.13 and 2024.Q1.1 through 2024.Q1.20 allows an remote authenticated attacker to inject JavaScript through the organization site names. The malicious payload is stored and executed without proper sanitization or escaping.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43787?

2 open source packages ship an affected version, including com.liferay:com.liferay.users.admin.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.users.admin.web` | Maven | From 6.0.6 | 11.0.33 |
| `com.liferay:com.liferay.users.admin.web` | Maven | From 6.0.6 | 11.0.33 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43787?

Upgrade com.liferay:com.liferay.users.admin.web to 11.0.33 or later.

## Is CVE-2025-43787 being exploited?

There is no known exploitation of CVE-2025-43787 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43787 and fix it if it is affected.

What it is: CVE-2025-43787 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 12 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43787 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.users.admin.web (Maven): affected from 6.0.6; fixed in 11.0.33
- com.liferay:com.liferay.users.admin.web (Maven): affected from 6.0.6; fixed in 11.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43787/ (Markdown: https://insights.sbomify.com/CVE-2025-43787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43787
- OSV: https://osv.dev/vulnerability/CVE-2025-43787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43787/
Summaries are generated and may contain mistakes; the official description above is the record.
