# CVE-2025-43792: Liferay Portal has External Control of System or Configuration Settings

> Authenticated attackers can exfiltrate data to a controlled server via remote staging if they obtain the shared secret and whitelist their server.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-vp64-77c6-33h8

## What is CVE-2025-43792?

CVE-2025-43792 is a low-severity server-side request forgery vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Remote staging in Liferay Portal 7.4.0 through 7.4.3.105, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions does not properly obtain the remote address of the live site from the database which, which allows remote authenticated users to exfiltrate data to an attacker controlled server (i.e., a fake “live site”) via the _com_liferay_exportimport_web_portlet_ExportImportPortlet_remoteAddress and _com_liferay_exportimport_web_portlet_ExportImportPortlet_remotePort parameters. To successfully exploit this vulnerability, an attacker must also successfully obtain the staging server’s shared secret and add the attacker controlled server to the staging server’s whitelist.

Weakness: CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2025-43792?

2 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.kernel. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.kernel` | Maven | All versions | 130.0.1 |
| `com.liferay.portal:com.liferay.portal.kernel` | Maven | All versions | 130.0.1 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43792?

Upgrade com.liferay.portal:com.liferay.portal.kernel to 130.0.1 or later.

## Is CVE-2025-43792 being exploited?

There is no known exploitation of CVE-2025-43792 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43792 and fix it if it is affected.

What it is: CVE-2025-43792 is a low-severity server-side request forgery vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43792 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.kernel (Maven): affected all versions; fixed in 130.0.1
- com.liferay.portal:com.liferay.portal.kernel (Maven): affected all versions; fixed in 130.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43792/ (Markdown: https://insights.sbomify.com/CVE-2025-43792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43792
- OSV: https://osv.dev/vulnerability/CVE-2025-43792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43792/
Summaries are generated and may contain mistakes; the official description above is the record.
