# CVE-2025-43798: Liferay DXP Missing Critical Step in Authentication

> Attackers can reuse TOTP codes to authenticate as users, leading to account takeover in Liferay DXP.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** GHSA-4p5r-3jmm-652q

## What is CVE-2025-43798?

CVE-2025-43798 is a low-severity authentication bypass vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92 and 7.3 GA through update 35 allows a time-based one-time password (TOTP) to be used multiple times during the validity period, which allows attackers with access to a user’s TOTP to authenticate as the user.

Weakness: CWE-304 (Missing Critical Step in Authentication)

## Which versions are affected by CVE-2025-43798?

2 open source packages ship an affected version, including com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web` | Maven | All versions | 2.0.25 |
| `com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web` | Maven | All versions | 2.0.25 |

Products: Liferay Digital Experience Platform.

## How do I fix CVE-2025-43798?

Upgrade com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web to 2.0.25 or later.

## Is CVE-2025-43798 being exploited?

There is no known exploitation of CVE-2025-43798 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43798 and fix it if it is affected.

What it is: CVE-2025-43798 is a low-severity authentication bypass vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43798 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web (Maven): affected all versions; fixed in 2.0.25
- com.liferay:com.liferay.multi.factor.authentication.timebased.otp.web (Maven): affected all versions; fixed in 2.0.25

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43798/ (Markdown: https://insights.sbomify.com/CVE-2025-43798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43798
- OSV: https://osv.dev/vulnerability/CVE-2025-43798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43798/
Summaries are generated and may contain mistakes; the official description above is the record.
