# CVE-2025-43801: Liferay Portal has unchecked input for loop condition vulnerability in XML-RPC

> Remote attackers can cause denial of service in Liferay Portal via crafted XML-RPC requests due to unchecked loop conditions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** GHSA-95h4-8mqc-4mpf

## What is CVE-2025-43801?

CVE-2025-43801 is a medium-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Unchecked input for loop condition vulnerability in XML-RPC in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions allows remote attackers to perform a denial-of-service (DoS) attacks via a crafted XML-RPC request.

Weakness: CWE-606 (Unchecked Input for Loop Condition)

## Which versions are affected by CVE-2025-43801?

2 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.impl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 101.0.0 |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 101.0.0 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43801?

Upgrade com.liferay.portal:com.liferay.portal.impl to 101.0.0 or later.

## Is CVE-2025-43801 being exploited?

There is no known exploitation of CVE-2025-43801 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43801 and fix it if it is affected.

What it is: CVE-2025-43801 is a medium-severity denial of service vulnerability in Liferay Digital Experience Platform, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43801 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 101.0.0
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 101.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43801/ (Markdown: https://insights.sbomify.com/CVE-2025-43801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43801
- OSV: https://osv.dev/vulnerability/CVE-2025-43801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43801/
Summaries are generated and may contain mistakes; the official description above is the record.
