# CVE-2025-43802: Liferay Stored Cross-site Scripting vulnerability

> Remote attackers can inject arbitrary web script or HTML via the externalReferenceCode parameter in Liferay Portal's custom object API endpoint.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 16 Sep 2025
- **Also known as:** GHSA-vg6h-g5mr-9hgv

## What is CVE-2025-43802?

CVE-2025-43802 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Stored cross-site scripting (XSS) vulnerability in a custom object’s /o/c/<object-name> API endpoint in Liferay Portal 7.4.3.51 through 7.4.3.109, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 update 51 through update 92, and 7.3 update 33 through update 35. allows remote attackers to inject arbitrary web script or HTML via the externalReferenceCode parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-43802?

2 open source packages ship an affected version, including com.liferay.workspace:com.liferay.ticket.workspace. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.workspace:com.liferay.ticket.workspace` | Maven | All versions | 20240122.0632 |
| `com.liferay.workspace:com.liferay.ticket.workspace` | Maven | All versions | 20240122.0632 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43802?

Upgrade com.liferay.workspace:com.liferay.ticket.workspace to 20240122.0632 or later.

## Is CVE-2025-43802 being exploited?

There is no known exploitation of CVE-2025-43802 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43802 and fix it if it is affected.

What it is: CVE-2025-43802 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-43802 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.workspace:com.liferay.ticket.workspace (Maven): affected all versions; fixed in 20240122.0632
- com.liferay.workspace:com.liferay.ticket.workspace (Maven): affected all versions; fixed in 20240122.0632

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43802/ (Markdown: https://insights.sbomify.com/CVE-2025-43802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43802
- OSV: https://osv.dev/vulnerability/CVE-2025-43802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43802/
Summaries are generated and may contain mistakes; the official description above is the record.
