# CVE-2025-43806: Liferay Portal and DXP does not properly check permission with import and export tasks

> Authenticated users can access exported data via REST APIs due to missing permission checks in Batch Engine.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 23 Sep 2025
- **Also known as:** GHSA-pm45-xx4q-fmv7

## What is CVE-2025-43806?

CVE-2025-43806 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 22 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Batch Engine in Liferay Portal 7.4.0 through 7.4.3.112, and Liferay DXP 2023.Q4.0 through 2023.Q4.7, 2023.Q3.1 through 2023.Q3.10, and 7.4 GA through update 92 does not properly check permission with import and export tasks, which allows remote authenticated users to access the exported data via the REST APIs.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-43806?

4 open source packages ship an affected version, including com.liferay:com.liferay.batch.engine.service and com.liferay:com.liferay.headless.batch.engine.impl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.batch.engine.service` | Maven | All versions | 4.0.102 |
| `com.liferay:com.liferay.batch.engine.service` | Maven | All versions | 4.0.102 |
| `com.liferay:com.liferay.headless.batch.engine.impl` | Maven | All versions | 4.0.52 |
| `com.liferay:com.liferay.headless.batch.engine.impl` | Maven | All versions | 4.0.52 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43806?

Upgrade com.liferay:com.liferay.batch.engine.service to 4.0.102 or later.

## Is CVE-2025-43806 being exploited?

There is no known exploitation of CVE-2025-43806 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43806 and fix it if it is affected.

What it is: CVE-2025-43806 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 22 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43806 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.batch.engine.service (Maven): affected all versions; fixed in 4.0.102
- com.liferay:com.liferay.batch.engine.service (Maven): affected all versions; fixed in 4.0.102
- com.liferay:com.liferay.headless.batch.engine.impl (Maven): affected all versions; fixed in 4.0.52
- com.liferay:com.liferay.headless.batch.engine.impl (Maven): affected all versions; fixed in 4.0.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43806/ (Markdown: https://insights.sbomify.com/CVE-2025-43806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43806
- OSV: https://osv.dev/vulnerability/CVE-2025-43806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43806/
Summaries are generated and may contain mistakes; the official description above is the record.
