# CVE-2025-43813: Liferay Portal vulnerable to path traversal and denial-of-service in the ComboServlet

> Remote attackers can access arbitrary CSS and JSS files and cause denial of service via path traversal in Liferay Portal's ComboServlet.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Sep 2025
- **Updated:** 30 Sep 2025
- **Also known as:** GHSA-2hm7-r8f3-423h

## What is CVE-2025-43813?

CVE-2025-43813 is a medium-severity path traversal vulnerability in Liferay Digital Experience Platform, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Possible path traversal vulnerability and denial-of-service in the ComboServlet in Liferay Portal 7.4.0 through 7.4.3.107, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 35, and older unsupported versions allows remote attackers to access arbitrary CSS and JSS files and load the files multiple times via the query string in a URL.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-43813?

4 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.impl and com.liferay.portal:release.portal.bom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 96.0.0 |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 96.0.0 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.0-ga1 | 7.4.3.108-ga108 |
| `com.liferay.portal:release.portal.bom` | Maven | From 7.4.0-ga1 | 7.4.3.108-ga108 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43813?

Upgrade com.liferay.portal:com.liferay.portal.impl to 96.0.0 or later.

## Is CVE-2025-43813 being exploited?

There is no known exploitation of CVE-2025-43813 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43813 and fix it if it is affected.

What it is: CVE-2025-43813 is a medium-severity path traversal vulnerability in Liferay Digital Experience Platform, published on 29 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43813 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 96.0.0
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 96.0.0
- com.liferay.portal:release.portal.bom (Maven): affected from 7.4.0-ga1; fixed in 7.4.3.108-ga108
- com.liferay.portal:release.portal.bom (Maven): affected from 7.4.0-ga1; fixed in 7.4.3.108-ga108

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43813/ (Markdown: https://insights.sbomify.com/CVE-2025-43813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43813
- OSV: https://osv.dev/vulnerability/CVE-2025-43813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43813/
Summaries are generated and may contain mistakes; the official description above is the record.
