# CVE-2025-43814: Liferay Portal and DXP audit events record password reminder answers

> Authenticated users can retrieve other users' password reminder answers from audit logs, exposing sensitive security questions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2025
- **Updated:** 23 Sep 2025
- **Also known as:** GHSA-ph63-chvv-8x46

## What is CVE-2025-43814?

CVE-2025-43814 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 22 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Liferay Portal 7.4.0 through 7.4.3.112, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.8, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, and older unsupported versions the audit events records a user’s password reminder answer, which allows remote authenticated users to obtain a user’s password reminder answer via the audit events.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2025-43814?

2 open source packages ship an affected version, including com.liferay:com.liferay.portal.security.audit.event.generators.user.management. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.portal.security.audit.event.generators.user.management` | Maven | All versions | 5.0.13 |
| `com.liferay:com.liferay.portal.security.audit.event.generators.user.management` | Maven | All versions | 5.0.13 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43814?

Upgrade com.liferay:com.liferay.portal.security.audit.event.generators.user.management to 5.0.13 or later.

## Is CVE-2025-43814 being exploited?

There is no known exploitation of CVE-2025-43814 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43814 and fix it if it is affected.

What it is: CVE-2025-43814 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 22 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43814 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.portal.security.audit.event.generators.user.management (Maven): affected all versions; fixed in 5.0.13
- com.liferay:com.liferay.portal.security.audit.event.generators.user.management (Maven): affected all versions; fixed in 5.0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43814/ (Markdown: https://insights.sbomify.com/CVE-2025-43814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43814
- OSV: https://osv.dev/vulnerability/CVE-2025-43814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43814/
Summaries are generated and may contain mistakes; the official description above is the record.
