# CVE-2025-43827: Liferay Portal Vulnerable to IDOR via audit events

> Authenticated users can view audit events from other virtual instances by manipulating the audit event ID parameter.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Sep 2025
- **Updated:** 30 Sep 2025
- **Also known as:** GHSA-pw86-qvx9-34r7

## What is CVE-2025-43827?

CVE-2025-43827 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 30 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Insecure Direct Object Reference (IDOR) vulnerability with audit events in Liferay Portal 7.4.0 through 7.4.3.117, and older unsupported versions, and Liferay DXP 2024.Q1.1 through 2024.Q1.5, 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, and older unsupported versions allows remote authenticated users to from one virtual instance to view the audit events from a different virtual instance via the _com_liferay_portal_security_audit_web_portlet_AuditPortlet_auditEventId parameter.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-43827?

4 open source packages ship an affected version, including com.liferay:com.liferay.portal.security.audit.storage.service and com.liferay:com.liferay.portal.security.audit.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.portal.security.audit.storage.service` | Maven | From 6.0.4 | 6.0.41 |
| `com.liferay:com.liferay.portal.security.audit.storage.service` | Maven | From 6.0.4 | 6.0.41 |
| `com.liferay:com.liferay.portal.security.audit.web` | Maven | From 5.0.1 | 5.0.33 |
| `com.liferay:com.liferay.portal.security.audit.web` | Maven | From 5.0.1 | 5.0.33 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-43827?

Upgrade com.liferay:com.liferay.portal.security.audit.storage.service to 6.0.41 or later.

## Is CVE-2025-43827 being exploited?

There is no known exploitation of CVE-2025-43827 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43827 and fix it if it is affected.

What it is: CVE-2025-43827 is a medium-severity missing authorization vulnerability in Liferay Digital Experience Platform, published on 30 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43827 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.portal.security.audit.storage.service (Maven): affected from 6.0.4; fixed in 6.0.41
- com.liferay:com.liferay.portal.security.audit.storage.service (Maven): affected from 6.0.4; fixed in 6.0.41
- com.liferay:com.liferay.portal.security.audit.web (Maven): affected from 5.0.1; fixed in 5.0.33
- com.liferay:com.liferay.portal.security.audit.web (Maven): affected from 5.0.1; fixed in 5.0.33

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43827/ (Markdown: https://insights.sbomify.com/CVE-2025-43827/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43827
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43827
- OSV: https://osv.dev/vulnerability/CVE-2025-43827

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43827/
Summaries are generated and may contain mistakes; the official description above is the record.
