# CVE-2025-43855: tRPC 11 WebSocket DoS Vulnerability

> Unauthenticated attackers can crash tRPC WebSocket servers by sending invalid connection parameters, requiring WebSocket and createContext configuration.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 14 May 2025
- **Also known as:** GHSA-pj3v-9cm8-gvj8

## What is CVE-2025-43855?

CVE-2025-43855 is a high-severity denial of service vulnerability in trpc, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

tRPC allows users to build & consume fully typesafe APIs without schemas or code generation. In versions starting from 11.0.0 to before 11.1.1, an unhandled error is thrown when validating invalid connectionParams which crashes a tRPC WebSocket server. This allows any unauthenticated user to crash a tRPC 11 WebSocket server. Any tRPC 11 server with WebSocket enabled with a createContext method set is vulnerable. This issue has been patched in version 11.1.1.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-43855?

2 open source packages ship an affected version, including @trpc/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@trpc/server` | npm | From 11.0.0 | 11.1.1 |
| `@trpc/server` | npm | From 11.0.0 | 11.1.1 |

## How do I fix CVE-2025-43855?

Upgrade @trpc/server to 11.1.1 or later.

## Is CVE-2025-43855 being exploited?

There is no known exploitation of CVE-2025-43855 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43855 and fix it if it is affected.

What it is: CVE-2025-43855 is a high-severity denial of service vulnerability in trpc, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43855 in the wild and no public exploit code.

Affected packages and fixed versions:
- @trpc/server (npm): affected from 11.0.0; fixed in 11.1.1
- @trpc/server (npm): affected from 11.0.0; fixed in 11.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43855/ (Markdown: https://insights.sbomify.com/CVE-2025-43855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43855
- OSV: https://osv.dev/vulnerability/CVE-2025-43855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43855/
Summaries are generated and may contain mistakes; the official description above is the record.
