# CVE-2025-43858: YoutubeDLSharp allows command injection on windows system due to non sanitized arguments

> Attackers can execute arbitrary commands on Windows systems via unsanitized arguments in the YoutubeDLSharp library.

- **Severity:** Critical 9.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-2jh5-g5ch-43q5

## What is CVE-2025-43858?

CVE-2025-43858 is a critical command injection vulnerability in Bluegrams YoutubeDLSharp, published on 24 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

YoutubeDLSharp is a wrapper for the command-line video downloaders youtube-dl and yt-dlp. In versions starting from 1.0.0-beta4 and prior to 1.1.2, an unsafe conversion of arguments allows the injection of a malicious commands when starting `yt-dlp` from a commands prompt running on Windows OS with the `UseWindowsEncodingWorkaround` value defined to true (default behavior). If a user is using built-in methods from the YoutubeDL.cs file, the value is true by default and a user cannot disable it from these methods. This issue has been patched in version 1.1.2.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2025-43858?

2 open source packages ship an affected version, including YoutubeDLSharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `YoutubeDLSharp` | NuGet | From 1.0.0-beta4 | 1.1.2 |
| `YoutubeDLSharp` | NuGet | From 1.0.0-beta4 | 1.1.2 |

## How do I fix CVE-2025-43858?

Upgrade YoutubeDLSharp to 1.1.2 or later.

## Is CVE-2025-43858 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43858 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43858 and fix it if it is affected.

What it is: CVE-2025-43858 is a critical command injection vulnerability in Bluegrams YoutubeDLSharp, published on 24 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43858 exists.

Affected packages and fixed versions:
- YoutubeDLSharp (NuGet): affected from 1.0.0-beta4; fixed in 1.1.2
- YoutubeDLSharp (NuGet): affected from 1.0.0-beta4; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43858/ (Markdown: https://insights.sbomify.com/CVE-2025-43858/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43858
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43858
- OSV: https://osv.dev/vulnerability/CVE-2025-43858

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43858/
Summaries are generated and may contain mistakes; the official description above is the record.
