# CVE-2025-43859: h11 accepts some malformed Chunked-Encoding bodies

> Attackers can perform request smuggling by exploiting lenient chunked-encoding parsing in the h11 library when used with a vulnerable proxy.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2025
- **Updated:** 24 Apr 2025
- **Also known as:** CLEANSTART-2026-MQ93716, CLEANSTART-2026-UA31108, CLSA-2026-1767571924, CLSA-2026-1790929139, DEBIAN-CVE-2025-43859, GHSA-vqfr-h8mv-ghfj, MINI-ggmr-vfcf-g97w, MINI-qmq9-59w4-rgr3, OESA-2025-1496, OESA-2025-1497, PYSEC-2026-348, RHSA-2025:7535, RHSA-2025:7536, ROOT-APP-PYPI-CVE-2025-43859, SUSE-SU-2025:1430-1, SUSE-SU-2025:20330-1, SUSE-SU-2025:20331-1, UBUNTU-CVE-2025-43859, USN-7503-1, openSUSE-SU-2025:15032-1

## What is CVE-2025-43859?

CVE-2025-43859 is a critical vulnerability in python-hyper h11, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

h11 is a Python implementation of HTTP/1.1. Prior to version 0.16.0, a leniency in h11's parsing of line terminators in chunked-coding message bodies can lead to request smuggling vulnerabilities under certain conditions. This issue has been patched in version 0.16.0. Since exploitation requires the combination of buggy h11 with a buggy (reverse) proxy, fixing either component is sufficient to mitigate this issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-43859?

3 open source packages ship an affected version, including h11.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `h11` | PyPI | All versions | 0.16.0 |
| `h11` | PyPI | All versions | 0.16.0 |
| `h11` | PyPI | All versions | 0.16.0 |
| `python-h11` | Red Hat:openstack:17.1::el9 | All versions | 0:0.12.0-2.1.el9ost |
| `python3-h11` | Red Hat:openstack:17.1::el9 | All versions | 0:0.12.0-2.1.el9ost |
| `python-h11` | Red Hat:openstack:18.0::el9 | All versions | 0:0.12.0-4.el9ost |
| `python3-h11` | Red Hat:openstack:18.0::el9 | All versions | 0:0.12.0-4.el9ost |
| `python-h11` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | SUSE:Linux Micro 6.0 | All versions | 0.16.0-1.1 |
| `python-httpcore` | SUSE:Linux Micro 6.0 | All versions | 0.16.3-7.1 |
| `python-h11` | SUSE:Linux Micro 6.1 | All versions | 0.16.0-slfo.1.1_1.1 |
| `python-httpcore` | SUSE:Linux Micro 6.1 | All versions | 0.16.3-slfo.1.1_2.1 |
| `python-h11` | openSUSE:Leap 15.6 | All versions | 0.14.0-150400.9.6.1 |
| `python-h11` | openSUSE:Tumbleweed | All versions | 0.16.0-1.1 |

## How do I fix CVE-2025-43859?

Upgrade h11 to 0.16.0 or later.

## Is CVE-2025-43859 being exploited?

There is no known exploitation of CVE-2025-43859 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43859 and fix it if it is affected.

What it is: CVE-2025-43859 is a critical vulnerability in python-hyper h11, published on 24 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43859 in the wild and no public exploit code.

Affected packages and fixed versions:
- h11 (PyPI): affected all versions; fixed in 0.16.0
- h11 (PyPI): affected all versions; fixed in 0.16.0
- h11 (PyPI): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43859/ (Markdown: https://insights.sbomify.com/CVE-2025-43859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43859
- OSV: https://osv.dev/vulnerability/CVE-2025-43859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43859/
Summaries are generated and may contain mistakes; the official description above is the record.
