CVE-2025-43863 vantage6 lacks brute-force protection on change password functionality

Low 1.7 Published Updated

An attacker with an authenticated session can brute-force user passwords via the change password endpoint due to missing rate limiting.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-43863?

CVE-2025-43863 is a low-severity vulnerability in vantage6, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.

Weakness: CWE-307

Which versions are affected by CVE-2025-43863?

3 open source packages ship an affected version, including vantage6. It affects 1 product.

PackageAffectedFixed in
vantage6 PyPIAll versions4.11.0
vantage6 PyPIAll versions4.11.0
vantage6 PyPIAll versions4.11.0

Products include Vantage6 Vantage6.

How do I fix CVE-2025-43863?

Upgrade vantage6 to 4.11.0 or later.

Is CVE-2025-43863 being exploited?

There is no known exploitation of CVE-2025-43863 in the wild and no public exploit code.

Sources

Also known as GHSA-j6g5-p62x-58hw, PYSEC-2025-220.

Is CVE-2025-43863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free