# CVE-2025-43863: vantage6 lacks brute-force protection on change password functionality

> An attacker with an authenticated session can brute-force user passwords via the change password endpoint due to missing rate limiting.

- **Severity:** Low 1.7 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2025
- **Updated:** 12 Jun 2025
- **Also known as:** GHSA-j6g5-p62x-58hw, PYSEC-2025-220

## What is CVE-2025-43863?

CVE-2025-43863 is a low-severity vulnerability in vantage6, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.

Weakness: CWE-307 (Improper Restriction of Excessive Authentication Attempts)

## Which versions are affected by CVE-2025-43863?

3 open source packages ship an affected version, including vantage6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.11.0 |
| `vantage6` | PyPI | All versions | 4.11.0 |
| `vantage6` | PyPI | All versions | 4.11.0 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2025-43863?

Upgrade vantage6 to 4.11.0 or later.

## Is CVE-2025-43863 being exploited?

There is no known exploitation of CVE-2025-43863 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43863 and fix it if it is affected.

What it is: CVE-2025-43863 is a low-severity vulnerability in vantage6, published on 12 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-43863 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.11.0
- vantage6 (PyPI): affected all versions; fixed in 4.11.0
- vantage6 (PyPI): affected all versions; fixed in 4.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43863/ (Markdown: https://insights.sbomify.com/CVE-2025-43863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43863
- OSV: https://osv.dev/vulnerability/CVE-2025-43863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43863/
Summaries are generated and may contain mistakes; the official description above is the record.
