# CVE-2025-43864: React Router allows a DoS via cache poisoning by forcing SPA mode

> Attackers can force SPA mode via headers to corrupt SSR pages and poison caches, causing denial of service in React Router applications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2025
- **Updated:** 25 Apr 2025
- **Also known as:** GHSA-f46r-rw29-r322

## What is CVE-2025-43864?

CVE-2025-43864 is a high-severity denial of service vulnerability in remix-run react-router, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. Starting in version 7.2.0 and prior to version 7.5.2, it is possible to force an application to switch to SPA mode by adding a header to the request. If the application uses SSR and is forced to switch to SPA, this causes an error that completely corrupts the page. If a cache system is in place, this allows the response containing the error to be cached, resulting in a cache poisoning that strongly impacts the availability of the application. This issue has been patched in version 7.5.2.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2025-43864?

2 open source packages ship an affected version, including react-router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 7.2.0 | 7.5.2 |
| `react-router` | npm | From 7.2.0 | 7.5.2 |

## How do I fix CVE-2025-43864?

Upgrade react-router to 7.5.2 or later.

## Is CVE-2025-43864 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43864 exists.

Public exploit code:

- https://github.com/pouriam23/DoS-via-cache-poisoning-by-forcing-SPA-mode-CVE-2025-43864- (github_poc): https://github.com/pouriam23/DoS-via-cache-poisoning-by-forcing-SPA-mode-CVE-2025-43864-

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43864 and fix it if it is affected.

What it is: CVE-2025-43864 is a high-severity denial of service vulnerability in remix-run react-router, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43864 exists.

Affected packages and fixed versions:
- react-router (npm): affected from 7.2.0; fixed in 7.5.2
- react-router (npm): affected from 7.2.0; fixed in 7.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43864/ (Markdown: https://insights.sbomify.com/CVE-2025-43864/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43864
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43864
- OSV: https://osv.dev/vulnerability/CVE-2025-43864

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43864/
Summaries are generated and may contain mistakes; the official description above is the record.
