# CVE-2025-43865: React Router allows pre-render data spoofing on React-Router framework mode

> Attackers can spoof pre-rendered data in React Router framework mode by manipulating request headers, requiring specific configuration to exploit.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2025
- **Updated:** 25 Apr 2025
- **Also known as:** GHSA-cpj6-fhp6-mr6j

## What is CVE-2025-43865?

CVE-2025-43865 is a high-severity vulnerability in remix-run react-router, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

React Router is a router for React. In versions on the 7.0 branch prior to version 7.5.2, it's possible to modify pre-rendered data by adding a header to the request. This allows to completely spoof its contents and modify all the values ​​of the data object passed to the HTML. This issue has been patched in version 7.5.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2025-43865?

2 open source packages ship an affected version, including react-router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `react-router` | npm | From 7.0.0-pre.0 | 7.5.2 |
| `react-router` | npm | From 7.0.0-pre.0 | 7.5.2 |

## How do I fix CVE-2025-43865?

Upgrade react-router to 7.5.2 or later.

## Is CVE-2025-43865 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43865 exists.

Public exploit code:

- https://github.com/pouriam23/Pre-render-data-spoofing-on-React-Router-framework-mode-CVE-2025-43865 (github_poc): https://github.com/pouriam23/Pre-render-data-spoofing-on-React-Router-framework-mode-CVE-2025-43865

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-43865 and fix it if it is affected.

What it is: CVE-2025-43865 is a high-severity vulnerability in remix-run react-router, published on 25 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-43865 exists.

Affected packages and fixed versions:
- react-router (npm): affected from 7.0.0-pre.0; fixed in 7.5.2
- react-router (npm): affected from 7.0.0-pre.0; fixed in 7.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-43865/ (Markdown: https://insights.sbomify.com/CVE-2025-43865/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-43865
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-43865
- OSV: https://osv.dev/vulnerability/CVE-2025-43865

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-43865/
Summaries are generated and may contain mistakes; the official description above is the record.
